Call Disruptions

Incident Report for Regal AI

Resolved

Twilio has confirmed that this issue has been resolved.
Posted Apr 15, 2025 - 13:54 EDT

Monitoring

Twilio has reported that the errors have stopped and our monitoring shows the same.

We will continue to monitor the situation and provide further updates once Twilio has confirmed the issue is fully resolved.
Posted Apr 15, 2025 - 11:24 EDT

Identified

We're currently experiencing intermittent issues with voice calls due to an incident impacting our provider, Twilio. Twilio has acknowledged the problem and their engineering team is actively investigating.

We’re monitoring the situation closely and will share updates as they become available. Thank you for your patience.
Posted Apr 15, 2025 - 10:45 EDT
This incident affected: Telephony (Twilio (Voice)).